viernes, 9 de marzo de 2012

Uso de Router Cisco 2800 2600, 3600 como dhcp server.

El tema de utilizar un servidor DHCP o no, depende principalmente del tamaño de la red y de la forma de administrar la misma, es decir si la persona que administra la red esta dispuesta a realizar estas configuraciones o no. 

También dependerá de la existencia o carencia de los recursos, tanto de hardware como de software. Para los que estén convencidos que utilizar un entorno de asignación de direcciones IP por medio  de DHCP, utilizando un enrutador cisco 2811 como dhcp server, les recomiendo este pequeño documento.

DHCP es un protocolo que permite a dispositivos individuales en una red obtener su propia información de configuración de red, tal como la dirección IP; máscara de sub-red, puerta de enlace, servidores dns, etc. El propósito principal es hacer más fáciles de administrar las redes grandes. Sin la ayuda de un servidor DHCP, tendrían que configurarse de forma manual cada dirección IP de cada equipo en la red. Un servidor DHCP supervisa y distribuye las direcciones IP de una Red de Área Local asignando una dirección IP a cada equipo que se una a la Red de Área Local. 

 Para el siguiente manual, utilizaremos un enrutador cisco 2811, utilizando el mismo como default gateway hacia el Internet, también utilizaremos el ejemplo con un servidor DNS local y un servidor DNS externo, tal como el asignado por un ISP. Para ver configuraciones sobre NAT  ver acá >> 

Para el ejemplo de la gráfica, se considera que el enrutador cisco 2811 esta funcionando para una red sencilla sin incluir vlans, a demás, estará realizando asignación de direcciones IP, servidor DNS1 y DNS2, al igual que el default gateway  a los clientes de red.


Configuracion del Enrutador 1

router1# configure terminal
router1(config)# ip dhcp pool red-local
router1(dhcp-config)# network 172.16.100.0  255.255.255.0
router1(dhcp-config)# default-router 172.16.100.1
router1(dhcp-config)# domain-name red.local
router1(dhcp-config)# dns-server 172.16.100.2  200.10.10.100

router1# show running-config  (versión reducida solo para ver las configuraciones realizadas!!)
!
!
ip dhcp pool red-local
   network 172.16.100.0  255.255.255.0
   default-router 172.16.100.1
   domain-name red.local
   dns-server 172.16.100.2  200.10.10.100
!
!
y las configuraciones de las Interfaces quedaría como las siguientes.
Router#1
!
interface FastEthernet0/0
 ip address 200.30.20.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.100.1 255.255.255.0
 duplex auto
 speed auto
!
!

4 comentarios:

Giovani Castillo (Ipswich) dijo...

Muy buena informacion, esta bastante clara, concisa, rapida y sin muchas vuelteretas de configuracion en el dispositivo. se agradece

DanielSaurio1989 dijo...

Muy útil su información. Quisiera que me ayuden con un problema que tengo al momento de configurar mi router, es un Cisco 3600; antiguo. Y quiero hacerlo funcionar como servidor DHCP, el problema es que al momento de declarar

router1(config)# ip dhcp pool red-local

no reconoce esa instrucción, ya intenté de todo, es de urgencia! cada que coloco

router1(config)# ip dhcp pool ?

y pongo el simbolo de interrogación para averiguar que debo colocar sin que me dé error me sale:



y no he podido avanzar con este tema. Agradecería muchísimo una ayuda. Gracias.

El Deza dijo...

esta intersante, pero en el caso de que yo tuviera dos VLANS conectadas al Switch, cómo sería la configuración?

Anónimo dijo...

Muy Buenas

Tengo un pequeño problema; el detalle es que necesito conectar un router serie 2800 a internet pero por medio de puerto gigaeth el ISp dejo el cable eth yo tengo un rango de ip´s y el gateway de esas ip´s pero no tengo ni idea cuales son los comandos para pegarme a internet directamente

Publicar un comentario