jueves, 3 de noviembre de 2011

Configuración básica de switches cisco 2950, 2960 parte1

Normalmente al comprar un switch cisco, basta con encenderlo y este comenzara a funcionar. Sin embargo todos los puertos por defecto pertenecen por defecto a la vlan 1, a demás tendrá las configuraciones generales. En esta sección presentare algunos comandos para configurar las necesidades básicas de un switch cisco 2960, por medio de la CLI.

Para acceder a modo de configuración usuario privilegiado es necesario introducir el comando enable
Switch>enable
Switch#

Posteriormente para acceder a modo de configuración global

switch#configure terminal   o bien puede ser switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Ya en modo de configuración global es posible realizar cambios a los parámetros de configuración del equipo como por ejemplo nombre, contraseñas, entre otros.

switch(config)#hostname switch1

switch1(config)#enable secret cisco

Definir la contraseña de acceso de enable, es decir al introducir el comando enable el switch le solicitara una contraseña.

Es importante configurar una contraseña a la consola, de tal manera que cuando un usuario intente conectarse a la interfaz de administración, se le solicite una contraseña, esto no es del todo excluyente porque cisco brinda un mecanismo de recuperación de la clave, sin embargo esto impedirá el acceso de manera fácil.


switch1(config)#line console 0
switch1(config-line)#password cisco1


Muy importante para toda persona que pretende acceder a los equipos de manera remota es configurar el acceso a las lineas vty..

switch1(config)#line vty 0 15
switch1(config-line)#password ciscovty
switch1(config-line)#login local

Una vez configurada el acceso al equipo es posible realizar las configuraciones especificas de cada una de las interfaces. Ejemplo para la interface f0/1

switch1(config)#int f0/1
switch1(config-if)#speed 100
switch1(config-if)#duplex full
switch1(config-if)#description <>

Configurar una dirección IP administrativa al switch, MUY Importante saber que esto solo se puede configurar en switches administrables, también es importante saber que los switches de capa 2 solamente pueden tener una dirección IP. Muy distinto lo que sucede en los switches que tiene funcionalidad de L3.

switch1(config)#interface vlan1
switch1(config-if)#ip address 192.168.1.10 255.255.255.0
switch1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Vlan1, changed state to up
switch1(config-if)#exit

En algunos casos resultara necesario configurar una ruta por defecto en los switches para garantizar que equipos que no se encuentran en la misma subred, puedan conectarse posteriormente.


Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#ip default-gateway 192.168.1.254

Una vez realizado estas configuraciones es posible visualizarlas mediante el uso de los comandos show

switch1#show running-conf

Building configuration...

Current configuration : 1222 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname switch1
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
interface FastEthernet0/1
 description <>
 duplex full
 speed 100
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
.
.
.
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 ip address 192.168.1.10 255.255.255.0
!
ip default-gateway 192.168.1.254
!
!
line con 0
 password cisco1
!
line vty 0 4
 password ciscovty
 login local
line vty 5 15
 password ciscovty
 login local
!
!
end


switch1#


Ver la parte2

3 comentarios:

Angeles dijo...

jejeje... esta genial, para los q se nos olvida de vez en cuando...

Ipswich dijo...

Muy buena info...

Anónimo dijo...

DOMINAR TODO ESTO ES LO QUE ME ARIA TAN FELIZ...QUE COMPLEJO .LO SUPERARE. GRACIAS

Publicar un comentario