martes, 31 de mayo de 2011

Servidor dhcp Linux, para múltiples Vlans


El Protocolo de configuración dinámica de servidores) es un protocolo que permite a dispositivos individuales en una red obtener su propia información de configuración de red, tal como la dirección IP; máscara de sub-red, puerta de enlace, servidores dns, etc. El propósito principal es hacer más fáciles de administrar las redes grandes.
Sin la ayuda de un servidor DHCP, tendrían que configurarse de forma manual cada dirección IP de cada equipo en la red. Un servidor DHCP supervisa y distribuye las direcciones IP de una Red de Área Local asignando una dirección IP a cada equipo que se una a la Red de Área Local.

Existen tres métodos de asignación en el protocolo DHCP: Asignación manual, Asignación automática y Asignación dinámica. En el ejemplo siguiente, se analizan dos de los casos.
Este documento explica de manera sencilla la forma de configurar un Servidor Linux, para que asigne direcciones por medio del dhcp a múltiples vlans.
 

Para el ejemplo de la gráfica, se considera que el servidor Linux1, funciona tiene configurado el direccionamiento de paquetes, es decir que esta configurado como un enrutador, al igual que funcionara como servidor dhcp. Para mas detalle sobre , Enrutador Linux >>
En redes pequeñas o medianas es posible utilizar el mismo equipo como servidor dhcp y como enrutador, sin embargo cuando la red crece es recomendable separar estas funciones, en equipos distintos. Siempre recordar que el puerto del switch donde se conecta el servidor dhcp, debe de ser configurado como troncal (IEEE 802.1Q). Para mas detalle sobre configuración de switches >>
En el ejemplo también se considera que existe un servidor dns, bien puede ser un servidor configurado en Linux o en Windows, este servidor pertenece a la vlan 100 y tiene configurada la dirección IP 172.16.100.2

 

Datos de la Redes vlan 2

Número de red de la vlan 2 172.16.2.0
Máscara de sub-red: 255.255.255.0
Puerta de enlace: 172.16.2.254 (Dir IP de la Interface vlan 2 en el servidor)
Servidor de nombres: 172.16.100.2


Datos de la Redes vlan3

Número de red de la vlan 3:  172.16.3.0
Máscara de sub-red: 255.255.255.0
Puerta de enlace: 172.16.3.254 (Dir IP de la Interface vlan 3 en el servidor)
Servidor de nombres: 172.16.100.2

Configuración del archivo /etc/dhcpd.conf


# Configuración para la red 172.16.3.0/24
# La red 172.16.3.0 la configuraremos de manera estática, es decir siempre le
# asignara la misma dirección IP a las computadoras.
# -------------------------------------------------------------------------------

subnet 172.16.3.0 netmask 255.255.255.0
{
option subnet-mask 255.255.255.0;
option broadcast-address 172.16.3.255;
option domain-name "test.com";
option domain-name-servers 172.16.100.2
option routers 172.16.3.254;

#Asignación de IP, a cada Maquina PC
host pc01
{
option host-name "pc01.test.com";
hardware ethernet 00:06:AB:AB:01:01;
fixed-address 172.16.3.1;
}

host pc02
{
hardware ethernet 00:06:AB:AB:02:02;
fixed-address 172.16.3.2;
}
}

# Configuración para la red 172.16.2.0/24
# Los datos de la red vlan 2 se asignan de manera dinámica
subnet 172.16.2.0 netmask 255.255.255.0
{
range 172.16.2.10 172.16.2.20;
option subnet-mask 255.2255.255.0;
option broadcast-address 172.16.2.255;
option domain-name "test.com";
option domain-name-servers 172.16.100.2;
option routers 172.16.2.254;
}



Configuración de las interfaces donde funcionará el servicio dhcp


Una buena medida de seguridad es hacer que el servicio de dhcpd solo funcione a través de la interfaz de red utilizada por la LAN, esto en el caso de tener múltiples dispositivos de red.

Edite el fichero /etc/sysconfig/dhcpd y agregue como argumento del parámetro DHCPDARGS el valor eth0, eth1, eth2, o en nuestro caso eth0.2, eth0.3.

# Command line options here
DHCPDARGS=eth0.2, eth0.3


Nota: para el ejemplo no agregamos la interface eth0.100 porque normalmente la asignación de direcciones en los servidores no se realiza por medio de dhcp.

Posteriormente solo queda arrancar el servicio dhcp.

/sbin/service dhcpd start o bien en el caso de Opensuse /etc/init.d/ dhcpd start
 
De esta manera resulta sencillo configurar el servidor linux dhcp para múltiples vlan, 
sin embargo si tiene dudas sobre la configuración de las subinterfaces en el servidor
linux, consulte el url configuración de un Enrutador Linux

11 comentarios:

Anónimo dijo...

En los datos de la Vlan2 y Vlan3 el identificador de red es igual para ambas 172.16.2.0? hay un errorcito verdad?

Derman Zepeda dijo...

Si claro,, se me escapo, ya lo revise... Gracias

Anónimo dijo...

Es posible utilizar mascaras de subred correspondiente a redes de clase C, para redes de clase B?

Derman Zepeda dijo...

Si por supuesto, esto debido a VLSM (máscaras de subred de tamaño variable), esto permite que tengas una red clase B y luego puedas realizar un diseño de sistema de direccionamiento y según necesites puedes tener algunas redes con mascaras /24.

Con vlsm, no importa la clase de la red, solo importa como lo desees segmentar.

Anónimo dijo...

Ok gracias.

Anónimo dijo...

Por fin se cómo hacerlo....ah,ah,ah.
Muchas gracias.

Anónimo dijo...

Que tal amigo, muy dicdactica tu explicacion, ahora me surge una duda, si quisiera tener configurado un router cisco para que me gestionara la subinterfaces que correspoderian a cada vlan, vlan1, vlan2, vlan3 etc, por poner un ejemplo, como haria en tal caso si quisiera tener un servidor linux como dhcp para todas estas vlan?, gracias de antemano por tu ayuda y respuesta

Derman Zepeda dijo...

Antes de todo, disculpa por no haberte contestado antes...

ok,,, acá te describo un poco sobre como hacerlo,,,


configuraciones en el router cisco....
//////////////////////////////////

interface FastEthernet0/1.2
description <>
encapsulation dot1Q 2
ip address 172.16.2.1 255.255.255.0
ip nat inside

interface FastEthernet0/1.3
description <>
encapsulation dot1Q 3
ip address 172.16.3.1 255.255.255.0
ip nat inside


Configuración en el servidor dhcp para la red 2
////////////////////////
# Configuración para la red 172.16.2.0/24, recuerda que la dirección ip de la interface vlan 2 en el servidor dhcp es la 172.16.2.254.
..................... ahora la configuracion seria la siguiente,,, solo cambias option routers
//////////////////////////////////////////////////

subnet 172.16.2.0 netmask 255.255.255.0
{
range 172.16.2.10 172.16.2.20;
option subnet-mask 255.2255.255.0;
option broadcast-address 172.16.2.255;
option domain-name "test.com";
option domain-name-servers 172.16.100.2;
option routers 172.16.2.1;
}


Espero que haya logrado explicarte esto,, de todos modos,, me has dado una idea para escribir sobre ese escenario,,,, Muchas gracias...

Anónimo dijo...

Buenas las pruebas se realizaron exitosamente en debian squezze 6 y un switch 3c0m 4200

Anónimo dijo...

Hola
He visitado este sitio muchas veces, por que tenia el primer esquema de red. Ahora necesito configurar como lo explica Anonimo con un switchL3 3COM y el servidor Linux.. He conseguido configurar el dhcp sin embargo este tambien hace de gateway hacia internet, me podrian ayudar como seria la configuracion.. Voy mucho tiempo y no lo he podido resolver

Edgar Sánchez dijo...

Hola muchas gracias por tu aporte, pero quisiera hacer dos preguntas, espero puedas responder pronto.
1) si deseara configurar nuestro servidor dentro de una de las dos vlans como sería?
2) hubo una cosa que no me quedo claro, donde declaras las interfaces, ese archivo es el mismo que en el que se crean las subnets?
Gracias de antemano

Publicar un comentario